Problem z WMS z geoportal.gov.pl w QGIS na Ubuntu

Na nowszych wersjach Ubuntu (20.04+) i QGIS (3.20+) pojawiły się problemy z wczytywaniem WMS i WMTS z GUGiK, które dostępne są spod domeny geoportal.gov.pl. Jest to spowodowane tym, że taka kombinacja wykorzystuje bibliotekę openssl 3, która przez serwer geoportalu obecnie nie jest wspierana.

Jeśli chcemy zachować możliwość wczytywania tych danych do QGIS (też przez wtyczkę GIS Support), jednym z rozwiązań jest dodanie kilku wpisów do lokalnej konfiguracji openssl. Aby to zrobić należy:

  1. Odszukać plik konfiguracjny. Polecenie openssl version -d powinno zwrócić nam folder, w którym się on znajduje. Domyślnie na systemie Ubuntu jest to /usr/lib/ssl/openssl.cnf
  2. Do pliku dodać następujące wpisy (jeśli jakaś sekcja lub wpis istnieje – pomijamy)

    1[openssl_init]
    2ssl_conf = ssl_sect
    3
    4[ssl_sect]
    5system_default = system_default_sect
    6
    7[system_default_sect]
    8Options = UnsafeLegacyRenegotiation

  3. Sprawdzamy czy usługi działają prawidłowo

UWAGA: Uruchomienie Unsafe Legacy Renegotiation naraża nas na podatność opisaną w  – ryzyko podejmujemy na własną odpowiedzalność.

 

2 odpowiedzi na “Problem z WMS z geoportal.gov.pl w QGIS na Ubuntu”

  1. Maciej pisze:

    Nie do końca rozumiem gdzie mam to wpisać to polecenie. W cmd?
    Pracuje na windowsie

Dodaj komentarz

Twój adres e-mail nie zostanie opublikowany. Wymagane pola są oznaczone *


Szkolenia GIS i QGIS

Szkolenia podstawowe i dedykowane w formie zdalnej oraz stacjjonarnej

Zobacz ofertę szkoleń